修改IntelliJ IDEA中Maven项目的默认JDK版本

在IntelliJ IDEA 15中使用Maven时,IDEA将默认的编译版本、源码版本设置为jdk5。编译项目的时候出现警告:”Warning:java: 源值1.5已过时, 将在未来所有发行版中删除”,并且无法编译jdk1.5以上的代码。

出现这样的原因应该是Maven插件的默认配置有问题。解决方法是在”pom.xml”里加入如下代码:

<properties>
<maven.compiler.source>1.8</maven.compiler.source>
<maven.compiler.target>1.8</maven.compiler.target>
</properties>

然后按”Ctrl+Shift+Alt+S”打开项目配置,设置Modules的Language Level为”8”:

01.jpg

最后按”Ctrl+Alt+S”打开设置,搜索”Java Compiler”,将默认jdk和当前modual的jdk版本切换为1.8即可:

02.jpg

写一段JDK8的代码,运行测试一下是否正常:

public class Test {
    public static void main(String[] args) {
        List<String> list = Arrays.asList("Hello", "World!");
        list.stream().forEach(System.out::println);
        }
}

转自:geekun的博客 原文链接:http://blog.csdn.net/geekun/article/details/51325510

发表评论

发表评论